SAP Knowledge Base Article - Public

2571164 - Longitude And Latitude Not Working

Symptom

You enter values for the Longitude and Latitude fields, however the system is not accepting these values.

Environment

SAP Hybris Cloud For Customer

Reproducing the Issue

  1. Go to the Customers work centre.
  2. Go to the Accounts view.
  3. Change filter to show All.
  4. Open: ABC (Where ABC stands for a Customer Account).
  5. Facet: Addresses.
  6. Pane: Details.
  7. Fields: Latitude and Longitude.
  8. Use a GPS Locating service, and for example choose SAP Galway.
  9. It will give you the following values: 53.30163340000001 and -8.987642499999993.
  10. Even though these are correct co-ordinates it will tell you these values are not valid.
  11. ** IF YOU CANNOT SEE THESE FIELDS PLEASE USE ADAPT **

Cause

The system does not accept this Longitude and Latitude format, as it will only accept a comma ' , ' not decimal points ' . '

Resolution

The system will only accept 17 digits before the comma, and only 14 decimal places are permitted in total.

An accepted format is:

  • Latitiude: 11,111111
  • Longitiude: -1,1111111

(You do not need the numbers that come after these - you can double check this in the GPS locator you are using. It does not change the location.)

Keywords

Latitiude, Longitiude, Not Working, Error , KBA , LOD-CRM-ACC , Account , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions