Symptom
The ship-to determination when creating a document from its facet on a customers Account appears to be random. Example facets: Tickets, Sales Order
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
Example used is the Ticket facet on Account, however, the same happens for Sales Order facet from Account.
- Go to the Customers work centre.
- Select the Account view.
- Search for the relevant Account XYZ (XYZ represents the ID of the Account).
- Navigate to the Tickets facet of the Account.
- Click on the New button and observe the ship-to field is automatically populated.
Cause
If there is no ship-to address with the main checkbox flagged in the Relationship facet of the Account, the system will randomly select a ship-to address when creating a new ticket. This is standard system behaviour.
Resolution
To avoid the ship-to being randomly selected, check the main checkbox beside one of the address in the Relationship facet of the account.
Keywords
account ship-to relationship, Sales Orders, Tickets, Ship to, Ship-to, Ship-to determination, random, account, ID, generating , KBA , LOD-CRM-ACC , Account , Problem