Symptom
When an e-mail sent from Cloud for Customer you would like to send e-mail using senders/business user e-mail address. However you are getting e-mail by default e-mail address such as "XYZ XYZ@example.com; on behalf of; donotreply@myXXXXXX.mail.crm.ondemand.com" (XYZ refers to the employee name, @example refers to the e-mail domain and XXXXXX refers to the tenant number).
Also, you already have selected the scoping question "Instead of the sender's name "on behalf of" the system's e-mail address, do you want to use only the employee".
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Send an e-mail through Cloud for Customer.
- Open the e-mail received by the recipient.
- Instead of the employee e-mail only, you will see "XYZ XYZ@example.com; on behalf of; donotreply@myXXXXXX.mail.crm.ondemand.com".
Cause
When the employee has no address e-mail or if it has an e-mail address which does not belongs to the configured domain under E-mail and Fax Settings fine-tuning, the system will pick the default one.
Resolution
-
Go to the Administrator work center.
- Go to the Users view.
- Select Employee.
- Search and open the employee XYZ.
- Click on Edit button.
- Add or change the e-mail address a domain belonging one.
See Also
Keywords
E-mail; on behalf of; , KBA , LOD-CRM-SC-EML , Email , LOD-CRM-SRP , Service Request Processing , How To