SAP Knowledge Base Article - Public

2559919 - The E-Mail Sent Via C4C Had the "on Behalf of" Instead of the Employee E-Mail Address

Symptom

When an e-mail sent from Cloud for Customer you would like to send e-mail using senders/business user e-mail address. However you are getting e-mail by default e-mail address such as "XYZ XYZ@example.com; on behalf of; donotreply@myXXXXXX.mail.crm.ondemand.com" (XYZ refers to the employee name, @example refers to the e-mail domain and XXXXXX refers to the tenant number).

Also, you already have selected the scoping question "Instead of the sender's name "on behalf of" the system's e-mail address, do you want to use only the employee".

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Send an e-mail through Cloud for Customer.
  2. Open the e-mail received by the recipient.
  3. Instead of the employee e-mail only, you will see "XYZ XYZ@example.com; on behalf of; donotreply@myXXXXXX.mail.crm.ondemand.com".

Cause

When the employee has no address e-mail or if it has an e-mail address which does not belongs to the configured domain under E-mail and Fax Settings fine-tuning, the system will pick the default one.

Resolution

  1. Go to the Administrator work center.
  2. Go to the Users view.
  3. Select Employee.
  4. Search and open the employee XYZ.
  5. Click on Edit button.
  6. Add or change the e-mail address a domain belonging one.

See Also

  2302750 - When Sending an E-Mail From an Activity The Sender is Not The Current User

Keywords

E-mail; on behalf of; , KBA , LOD-CRM-SC-EML , Email , LOD-CRM-SRP , Service Request Processing , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions