Symptom
'WARN - NO RECORDS' is displayed after connector has run. What does this mean?
Environment
SAP SuccessFactors Learning
Reproducing the Issue
Run an LMS connector: Learning Administration > System Administration > Connectors.
Cause
Possible causes:
- There was no text file available in the specified directory when the connector was scheduled to run.
- The file in the directory has incorrect file name format.
- The file is available but has no data in it.
- The file is available but the format is incorrect (headers, delimeters, end of line)
Resolution
The file must be uploaded to the correct server path with the correct file name.
To determine the correct path:
- Log in to LMS as Admin.
- Navigate through Learning Administration > System Administration > Configuration > System Configuration > CONNECTORS (Click the display icon).
- Search for 'connector.input.file.location'.
- If it is FTP, search for 'connector.ftp.input.remoteDirectory='. It states to which folder in the SFTP you need to place the file.
- The SFTP URL and account name are:
- connector.ftp.server=
- connector.ftp.userID=
- If it is local, search for 'connector.local.input.localDirectory='. It states to which folder in your local directory you need to place the file.
To determine the correct file name:
One easy way to determine the correct file name:
- Log in to LMS as Admin.
- Navigate through Learning Administration > System Administration > Connectors > ***Choose the connector type in concern***.
- Click 'View Results > View Logs'.
- Look for the 'WARN' line. It will show what file name is being looked for. Your file name should then be that file name.
To determine the correct format:
One easy way to know the correct format is to download the connector template:
- Log in to LMS as Admin
- Navigate through System Administration > Connectors > Download Connector Template
- Choose the connector that you need on the dropdown
- It will show you the supported files for that connector, choose what you need
- Click Submit
- Save the downloaded connector template
File is available but has no data in it:
This is the scenario where connector is able to read the input file properly however the input file contains 0 records. This is mostly an issue with the Job owner of the Employee export job in Provisioning.
Kindly make sure:
1. Job owner of Employee export job in Provisioning is active in Bizx
2. Job owner has 'Employee export' permission in Bizx.
For more details on this, Kindly refer to the KBA mentioned in the See Also Section. For more queries on Why Employee export job is returning 0 records, Please engage LOD-SF-PLT team.
See Also
Keywords
sf, success factors, LMS, connectors, input file , KBA , LOD-SF-LMS-CON , Connectors , How To