SAP Knowledge Base Article - Public

2458964 - Synchronise Business Configuration Job Failing due to Unknown Error (Error getRoleIdsRuleIdsMap for baseUserId)

Symptom

The Synchronise Business Configuration job is failing in Provisioning due to an unknown error. This job ensures the data models and manage business configuration are in sync

Job Details > error text you will see "Error getRoleIdsRuleIdsMap for baseUserId"

Environment

Employee Central - Business Configuration

Reproducing the Issue

  1. Login to Provisioing
  2. Go to Import Succession Data Model or Import Country-Specific Succession Data Model > import the XML
  3. XML is imported successfully
  4. Go to Monitor Jobs
  5. Search for Synchronise Business Configuration job and observe the job is failing due to an unknown error
  6. Click "Details" for the failed job and in the error text you will see "Error getRoleIdsRuleIdsMap for baseUserId"

Cause

THE Data Model XML is imported successfuly but it does not synchronize to the Business Configuration UI. This job fails with "KB-1 Error" and you can find in the job Details the following -: "Error getRoleIdsRuleIdsMap for baseUserId" if any one of the following objects are Secured by Role Based Permissions. It has never been supported to make these following objects secured.

  1. ActivityListObject
  2. EcElementConfig
  3. ECPersonElementConfig
  4. ECFieldConfig
  5. ECLocalElementConfig
  6. ObjectConfig
  7. ECLocalElementConfig
  8. ECSyncMapping
  9. ECTriggerRule
  10. EPBackGroundElementConfig
  11. EPFieldConfig
  12. EPUserInfoConfig

NOTE: The Synchronise Business Configuration job failure only occurs when importing the Data Models to update BCUI via Data Model import. Any updates made to the configuration via the BCUI will still synchronize to the Data Models.

Resolution

Identify:

The MDF Objects listed below must be Active in the system and must not be Secured. If you cannot find them, please Include Inactives in your search.

  • ActivityListObject
  • EcElementConfig
  • ECPersonElementConfig
  • ECFieldConfig
  • ECLocalElementConfig
  • ObjectConfig
  • ECLocalElementConfig
  • ECSyncMapping
  • ECTriggerRule
  • EPBackGroundElementConfig
  • EPFieldConfig
  • EPUserInfoConfig

(To "Include Inactives, click "Advanced" and change the drop-down to "Yes" and click OK > then search again) -:

inactive.png

Once you have found the Object, scroll to the bottom of the objects configuration to verify whether it is Secured -:

2017-04-16_10-47-22.png

If any of these objects are secured, then this job will fail due to an unknown [KB-1] error.

 

Solution:

Due to a recent change in behaviour to MDF > Configure Object Definitions page, which restricts all users (permissioned or not) from being able to use Take Action > Make Correction on pre-delivered, feature related MDF objects (ones that should not be secured or customized). Therefore you will need assistance from Product Support to have the issue resolved.

Therefore, please open a Support case with the SAP Cloud Product Support team who will need to engage with SAP SuccessFactors Development team, to run a script to remove the Security on these objects. Once the script has been completed/committed, the Synchronize Business Configuration job will execute without error the next time either the Succession Data Model or the Country Specific Succession Data Model are imported.

Please do try to provide the following information if possible to help speed up the resolution -:

  1. Instance ID of the impacted instance(s)
  2. Make sure the Secure Access user is defined for each of the impacted instances in the Secure Area of the case
  3. Submission Time of the Synchronize Business Configuration job
  4. Data Models you are trying to import (just for reference)

 

Once the script has been run, please log into the instance, and navigate to Admin Center > Configure Object Definitions > and verify all of the objects listed above, are no longer Secured.

Verify that the "Synchronise Business Configuration" job is no longer failing by importing either -:

  • Succession Data Model
  • Country Specific Succession Data Model

 

Next Steps:

Finally there are the following steps which must be completed to ensure your BCUI is properly refreshed. Log into the instance, go to Admin Center > Manage Business Configuration - If you only see Employee Profile elements/config listed, then please complete these steps -:

  1. Login to Provisioning > Company Settings > disable the feature "Enable Business Configuration in Admin Tools" and SAVE.
  2. Wait for the page to refresh and verify the feature is disabled.
  3. Then go to Provisioning > Company Settings > enable the feature "Enable Business Configuration in Admin Tools" and SAVE
  4. Wait for the page to refresh and verify the feature is enabled.
  5. Import the Succession Data Model > verify the Synchronize Business Configuration ran and completed successfully (Provisioning > Monitor Jobs)
  6. Import the Country Specific Succession Data Model > verify the Synchronize Business Configuration ran and completed successfully (Provisioning > Monitor Jobs)
  7. Log into Instance and go to Admin Center > Manage Business Configuration,  and verify that the BCUI is matching the Data Models.

Keywords

Synchronise Business Configuration, ECT-59713, Unknown Error, Manage Business Configuration, ECT-83250, ECT-84634, Error getRoleIdsRuleIdsMap for baseUserId, bcui, job failing, KB-1 Error, Error occurred. Please, see error details , KBA , LOD-SF-EC-BCI , Manage Business Configuration (BCUI) & Data Models (XML) , Problem

Product

SAP SuccessFactors Employee Central all versions