SAP Knowledge Base Article - Public

2458817 - Scheduled Workflow Rule to Trigger an E-Mail After a Defined Duration Does Not Work

Symptom

You have configured a scheduled Workflow rule and expect it to trigger an e-mail to the recipient after a defined duration of time, but it does not trigger a mail after the defined duration.

In our example, let us consider a Workflow rule that is scheduled to trigger an e-mail to the Owner responsible of a Lead, one minute after the Lead is created.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Administrator Workcenter
  2. Navigate to Workflow Rules View
  3. Click on New
  4. Create a new scheduled workflow rule as shown in the screenshot
  5. Now go to Sales Workcenter
  6. Navigate to Leads View
  7. Click on New and create a new Lead XYZ (where XYZ indicates the Lead ID)
  8. There is no e-mail triggered from the workflow after the duration defined

TST.png

 

Cause

This is because you defined the workflow rule to trigger an e-mail, one minute after Lead creation; on the field "Created On" which is of type "date". So for the Lead XYZ, which was created on let's say: DD/MM/YYYY, the time of workflow execution would be one minute after midnight (since the field is of type "date"), Hence, it would be 00:01 AM, which is in past of the time of creation of the Lead XYZ, consequently, the rule  execution gets cancelled with the reason that it was supposed to be executed in the past.

Resolution

To prevent this from occurring, modify the rule to trigger the e-mail one minute after Lead creation on the field "Creation Date time" which is of type date/time.

So now when the Lead will be created, the execution time of the workflow rule would be one minute ahead of the exact time of creation.

See Also

Example:

If the Lead is created at 10:00 AM, then the rule's execution time will be  at 10:01 AM and it will not get cancelled in this case as it is the future, unlike in the previous case.

Keywords

scheduled workflow, email workflow, workflow rules , KBA , timing , workflow , scheduled workflow , LOD-CRM-WKF , Workflow , How To

Product

SAP Cloud for Customer add-ins all versions