Symptom
- Once an OCN course is finished, it is not possible to review the content within the course from the Learning History.
- When trying to review the content from an OCN course, the access returns errors or does not properly authenticate.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Complete an OCN course >
- As a user, go to the Learning History >
- Click the course and click "Review Content" >
- There is no link to click in the content object, which makes impossible to open the content and review it.
Or
- Complete an OCN course >
- As a user, go to the Learning History >
- Click the course and click "Review Content" >
- There is the link to open the content, but the access/authentication does not properly happen.
Cause
Open Content Network contents send new data when a user launches them from their learning history. As the OCN vendor sends API calls with the completion information, they cannot distinguish that these courses are being reviewed rather than retaken, thus the user will receive a secondary completion.
Resolution
Due to multiple completions being sent as explained above, the ability to review OCN content is not possible/supported.
To change this functionality, please raise an enhancement request as per the steps mentioned in the KBA 2090228. The Learning Product Management team can further review and assess the requested functionality to be considered in a future release.
See Also
Settings That Control Online Content in a Learning Item
2301688 - Review Learning Content After Completion in Learning History
Keywords
review, open, network, OCN, Coursera, OpenSesame, Lynda, Harvard, LinkedIn, learning, history, completed, works, lms, unable, not, possible, content , KBA , LOD-SF-LMS-CNT , Content , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-ITE , Items , LOD-SF-LMS-OCN , Open Content Network , Problem