Symptom
When opening a Business Rule, you receive and application error message:
Environment
- Employee Central
- Configure Business Rules
- Message Definitions
Reproducing the Issue
1. Navigate to Admin Centre > Configure Business Rules
2. Select for a rule > Open Rule
3. Application Error occurs
Cause
If this rule is triggering a Raise Message, for example an Info, Warring or Error Message.
The Message Definition for this rule, may have been deleted from the instance or not imported into the instance when importing the rule.
If this is the case you may be able to correct the issue so you can view the business rule again without recreating it.
Resolution
• Navigate to "Manage Data" from the "Admin Centre".
• Select "Rule" from the for drop-down and then select the impacted business rule in the second drop-down:
• You will now see a code version of the business rule.
• Copy the test from the "body" section:
• Paste this text into a text editor for example Notepad++.
• Then search the text to see if a messageDefinition is used:
• Copy the Code of the messageDefinition and in "Manage Data" search for "messageDefinition" in the first drop-down and the code of the messageDefinition in the second.
• If the messageDefinition does not exist you can create a New one, with the exact same code in Mange Data:
• Once saved you will be able to open the Business Rule again:
See Also
2279954 - Application Error on viewing rule / ’Rule Type’ dropdown empty when creating a business rule
Keywords
Application Error, Business Rule, 6dd8163936f3d157424941d2ad6fdd25639f4ceb, go not found with type:MessageDefinition , KBA , LOD-SF-EC-JOB-RUL , Job Info Business Rules , LOD-SF-EC-CMP-RUL , Business Rules , LOD-SF-MDF-RUL , Custom Oject based Business Rules , Problem