SAP Knowledge Base Article - Public

2433230 - Warning Message: Party role Reported For is not deployed; please check the business configuration

Symptom

When you make a change to a Ticket, you see a message 'Party role Reported For is not deployed; please check the business configuration'.

Environment

SAP Cloud for Customer

Reproducing the Issue

Prerequisite: you have already created a Ticket ABC (ABC represents the Ticket ID).

  1. Go to the Service Work Centre.
  2. Go to the Tickets View.
  3. Open Ticket ID ABC.
  4. Make a change.
  5. Notice the message: 'Party role Reported For is not deployed; please check the business configuration'.

Cause

You have enabled Employee (Reported For) Party on screen. If you are using Customer Service scenario, the Employee is the Agent and therefore, the Employee field is hidden from the screen by standard. This is done on purpose as the Employee field is to be used in Employee Support scenario only.

Resolution

To solve the issue, delete the entries done on the Employee field and hide the field from the screen.

Also, when using Customer Service scenario, the Employee Support workcenter view should not be assigned to a User. In general, C4C application can be used to support both scenarios in the same system. However, if the same Employee needs to support both scenarios, two separate login users have to be created - one with Customer Service related workcenter views and one with Employee Support related workcenter views.

Keywords

Ticket, Employee, Party , KBA , LOD-CRM-EMP , Employee , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions