Symptom
You Replicate a Lead Using Webservice from a External System but The Status of the Lead is Always Set as Qualified and Qualification Cold
Cause
In the lead soap Manage Leads , if you assign any value in the Qualification Level, then it means the Lead is qualified, therefore the status of lead automatically will be switch to as example to 'Qualified' which is SAP C4C standard delivery.
Resolution
Small Guide for a better understanding of this functionality.
A) Check the soap when creating a lead via A2X.
Example:
...
<!--Optional:-->
<QualificationLevelCode>03</QualificationLevelCode>
<!--Optional:-->
...
If you set the code as above it means the Qualification = "Hot" , then the status of lead will be set to 'Qualified'. This behavior is the same as when you create a new lead in the UI or if you change the Qualification from default 'Cold' to "Hot", the Status will be set to 'Qualified' which is SAP C4C standard delivery.
B) Check if you have defined a Qualification status using workflow rule.
- Go to Administrator Work Center
- Workflow Rules View
Please check the rules to avoid conflict with the values defined in Soap like Extension fields.
C) Code List Restriction
It is possible that in Code List Restriction, the qualification level value is defaulted to warm or hot which will also change the status of the lead automatically to Qualified.
D) PDI Implementation
If you expect a different behavior in your logic status, you can implement your own logic via PDI Implementation to reset the status.
Example: In the lead we have an action called ResetQualification"RESET_QUALIFICATION" , in the PDI you can use it to reset the status.
Keywords
KBA , LOD-CRM , Cloud for Customer , How To