Symptom
- User Item status (csv) does not return the same result as Admin Item status (csv) report
- Item records missing in User item status (csv) report when compared to item status (csv) report ran by admin
Environment
- SAP SuccessFactors
- Learning Management System (LMS)
Reproducing the Issue
- Login to Learning Admin
- Navigate to System Admin > Reports icon in top right
- Search for Item Status (CSV) report
- Run report for a user
- Now go to learning > users> search the same user recode > view user record
- Action > Proxy user
- Links > Reports > Item Status > run Item Status (csv) for "self"
- Note that the results differ, the User version seems to be missing items
Cause
- The Administrator version of the Item Status (csv) report contains both inactive items and item records of old revision
- The User version only returns active items, old inactive revisions are not returned
Resolution
This is a limitation of the current reporting functionality of LMS Reports:
- User Item status (csv) report only contains item records that are "active" as user only have the visibility to active items
- User Item status (csv) report also list item's latest version
- All old revision items are excluded in User Item Status (CSV) report
See Also
- Please consider submitting an Enhancement Request for this functionality if needed
- More details on submitting Learning Enhancement Requests can be found in KBA 2090228
Keywords
SF SuccessFactors Learning Management System LMS item status (csv), user item status report, inconsistency in result, item status report, admin item status report missing gone different differ inactive old revision all display return show , KBA , LOD-SF-LMS-REP , Reporting Data , Problem
Product
SAP SuccessFactors Learning 1611