Symptom
Forms have not been removed for inactive employees.
Environment
- SAP SuccessFactors Performance Management
- SAP SuccessFactors 360 Multi-Rater
- SAP SuccessFactors Employee Central (EC)
- SAP SuccessFactors HXM Suite
Reproducing the Issue
- Process an employee termination
- Forms are still present for the employee
Cause
- Blocked jobs in the Check Tool
- Do Not Remove Inactive Employee's In-Progress/Completed Documents. is enabled in Form Template Settings
- Automatic Document Removal options were not enabled for processing via API
- Automatic Document Removal options were not enabled during import
- The User Data File (UDF) has not updated with the employee status
- (EC Only) Automatic Document Removal Settings are not enabled in the HRIS Sync
Resolution
- Blocked jobs in the Check Tool
- Review 2824417 - Document Transfer and Quick Fix - Configuration Check Tool - Performance Management to process a Quick Fix on the blocked job.
- NOTE: Once the Quick Fix has been applied, the system will automatically start processing any jobs that were held up by the blocked job. The system will need at least 24 hours to process the backlog of jobs. The length of time will be dependent on company size and the length of time the blocked job has been present.
- Do Not Remove Inactive Employee's In-Progress/Completed Documents. is enabled in Form Template Settings
- Navigate to Admin Center > Form Template Settings
- Select the form template
- Uncheck the options for Do Not Remove Inactive Employee's In-Progress/Completed Documents.
- Automatic Document Removal options were not enabled for processing via API
- Please review SAP SuccessFactors API Reference Guide (OData V2) - Creating and Editing Users Using an API Option Profile.
- Automatic Document Removal options were not enabled during import
- Please follow the steps in Managing Mass Changes in Employee Central - Configuring Additional Options with Basic Imports.
- NOTE: EC-enabled instances should not use Basic Import to change an employee status. A basic import causes inconsistent data between EC and the User.
- The User Data File (UDF) has not updated with the employee status
- Review the steps in Managing User Information - Exporting User Data to confirm the employee status has been updated. If the status has not been updated, please process the employee change again for forms to be processed.
- (EC Only) Automatic Document Removal Settings are not enabled in the HRIS Sync
- Please follow the steps in Implementing Employee Central Core - Creating a Job Request to Sync HRIS Data to enable the settings.
- Note:
- If the user status in Employee Profile is the same as the status in EC before the HRIS sync job runs, the HRIS sync job will not sync the user status and will not remove documents for inactive users.
- The system checks the Last Modified Date of the scheduled daily HRIS sync job with the settings enabled. It does not consider the manual run of HRIS sync.
Updating settings will only affect forms for future inactive employees. Present forms for inactive employees can be deleted manually:
See Also
- Implementing and Managing Performance Management - Form Template Settings
- Implementing and Managing 360 Reviews - Removing 360 Reviews Forms of Inactive Employees in Bulk
- Managing Mass Changes in Employee Central - Configuring Additional Options with Basic Imports
- Implementing Employee Central Core - Creating a Job Request to Sync HRIS Data
- SAP SuccessFactors API Reference Guide (OData V2) - Creating and Editing Users Using an API Option Profile
- Implementing and Managing Performance Management - Deleting Forms
Keywords
SF, Success Factors, PMGM, PM, EC, documents, employee, document, removal, options, settings, template, delete forms, multirater, multi rater, mtr, jobs, inactivate, deactivate, human resources information sync, syncing , KBA , LOD-SF-PM-FRM , Forms & Templates , LOD-SF-EC-HRS , HRIS Sync , LOD-SF-PM-REP , Reporting & Analytics, Data Imports & Exports , LOD-SF-EC-EMP , Employment Information (Employment Details) , Problem