SAP Knowledge Base Article - Public

2394761 - Error: 'Logon failed. HY000:A connection attempt failed...' when attempting to connect to Salesforce.com from Crystal Reports

Symptom

  • Logon failed.
  • Unable to connect to Salesforce.
  • Failed to refresh a report based off Saleforce.com
  • When attempting to logon to Salesforce.com from Crystal Reports, it fails with the error:
           
       'Logon failed.
        Details: HY000:A connection attempt failed because the connected
        party did not properly respond after a period of time, or established
        connection failed because connected host has failed to respond.
        [Database Vendor Code: 139 ]'
           
      
      Sforce Error - 09.png  
      
        
  • Note: Images and data in this SAP Knowledge Base Article is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP Crystal Reports 2013
  • SAP Crystal Reports 2016

Reproducing the Issue

  1. In Crystal Reports, create a new report.
  2. In the Database Expert window, double click on the Salesforce connection.
  3. Enter the Salesforce.com user name and password.
        
    It fails to logon.

Cause

  • It fails because there is a Proxy configured on the network to connect to the Internet, and the proxy setting is not added to the Salesforce.com connection.

Resolution

  • To add the proxy setting to the Salesforce.com connection for Crystal Reports:  
    1. Navigate to the location of CRConfig.xml file, which is located by default at:
          
        C:\Program Files (x86)\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\java\
             
    2. Open the CRConfig.xml file in text editor like Notepad.
             
    3. Add the following lines to the <SForce> section of the XML file, with your proxy settings:
             
           <UseProxy>TRUE</UseProxy> 
           <ProxyAddress> Add the proxy name here </ProxyAddress>
           <ProxyPort> Add the proxy port number here </ProxyPort>
              
             
      Below is an example of how the xml file will look after adding the proxy setting for the Salesforce.com connection,
      if the proxy name is: MyProxy, and the port number: 1234

           
           <SForce>
              <UseProxy>TRUE</UseProxy>
                    <ProxyAddress>MyProxy</ProxyAddress>
                    <ProxyPort>1234</ProxyPort>
                    <CacheRowSetSize>100</CacheRowSetSize>
                    <QueryBatchSize>2000</QueryBatchSize>
                    <SocketTimeout>600000</SocketTimeout>
                    <BatchLookupCacheJoinSize>200</BatchLookupCacheJoinSize>
           </SForce>

Keywords

CR, SForce , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem

Product

SAP Crystal Reports 2013 ; SAP Crystal Reports 2016