SAP Knowledge Base Article - Public

2359397 - Wrong G/L Account Determination for Line Items of a Customer Invoice on Services

Symptom

After posting a Customer Invoice for Services, you notice that the Automatic Account Determination is wrong for one of the Sets of Books i.e. you expect another G/L Account to be determined for the Line Items.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the General Ledger work center.
  2. Go to the Journal Entries subview.
  3. Search and display the relevant Journal Entry for your Customer Invoice.

For one of the Sets of Books, you notice the wrong G/L Account is being determined at the Line Items level.

  1. Go to the Product and Services Portfolio work center.
  2. Navigate to the Services view.
  3. Search for the Service XYZ (where XYZ is the Service ID).
  4. Click Edit and then View All.
  5. Go to the Valuation tab.
  6. Select the company involved in the business transaction.

You can see that the Account Determination Group maintained is ABC (where ABC is the Account Determination Group ID) and is the same for both Sets of Books.

Therefore, you expect that the Line Items are going to be determined based on the Account Determination Group ABC for this Service.

Cause

Even though the correct G/L Account is associated to the right Account Determination Group ABC in the Business Configuration activity Charts of Accounts, Financial Reporting Structures, Account Determination, you have maintained your data in a way that does not allow for the expected G/L Account to be determined.

The system determines the G/L account according to different sets of combinations that are prioritized differently:

Under the activity Charts of Accounts, Financial Reporting Structures, Account Determination

  • Navigate to Account Determination, select Sales.
  • Select the relevant Chart of Accounts
  • Go to the Revenues tab and choose 2 - Service in the scroll down menu.

The G/L Account that is determined is based on the combination of the values maintained in this screen.

Combination 1 - Highest Priority:

The Account Determination Group for Customers field, and the Account Determination Group for Services field are both maintained with relevant groups for the G/L Account maintained in Sales Revenue.

  • If this condition is not met, the system examines Combination 2.

Combination 2:

The Account Determination Group for Customers is maintained but the Account Determination Group for Services is not. The system is going to pick up the G/L Account maintained in Sales Revenue for this combination.

  • Lastly, if this condition is not met either, then the system examines the Combination 3 - Lowest Priority.

Combination 3 - Lowest Priority:

The Account Determination Group for Customers is not maintained but the Account Determination Group for Services is. The system determines the G/L account maintained in Sales Revenue as Line Item.

If you have maintained any values in any of the columns in this screen, please check the combinations above to identify what combination will be selected for the account determination.

Resolution

  1. Go to the Business Configuration work center.
  2. Go to the Implementation Projects, select the relevant one.
  3. Open the Activity List.
  4. Navigate to Fine Tune.
  5. Search for and open the Charts of Accounts, Financial Reporting Structures, Account Determination activity.
  6. Navigate to Account Determination, select Sales.
  7. Select the relevant Chart of Accounts.
  8. Navigate to the Revenues tab and choose 2 - Service in the scroll down menu.
  9. In the table displayed, you can see that the expected G/L Account is associated to an Account Determination Group for Services (ABC) but that Account Determination Group for Customers is left empty.

This configuration explains why the desired G/L Account is not picked up as a Line Item on your Journal Entry.

To address this situation, you can either change the G/L Account maintained in the other Combinations used by the system or that both the Account Determination Group for Customers and the Account Determination Group for Services are maintained with the relevant data for all G/L Accounts.

See Also

Keywords

gl account, g/l accounts, customer invoice, line item, service, product, account determination group, report, project , KBA , incorrect , unexpected , SRD-FIN-GL , General Ledger , How To

Product

SAP Business ByDesign all versions