Symptom
On a workflow with multiple Steps, CC Roles or Groups, not all expected notifications are being sent.
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- Go to Admin Center -> Manage Organization, Pay, and Job Structures
- Create or modify a workflow that have 2 or more CC Roles, Steps or Groups where the same employee is part of both steps, cc roles or groups
- Perform the changes that will trigger the workflow
- Upon triggering or completion/approval the expectation is that an email should be sent to participants based on all cc roles, steps and groups, regardless of whether they participate on multiple cc roles, steps and groups or not.
Cause
If the workflow participant belongs to multiple CC Roles, Steps or Groups only one notification is sent.
Resolution
System does not sent multiple emails to the same user. This is the expected system behavior.
If this is an important subject for your business requirements, kindly consider submitting an enhancement request by following 2090228.
See Also
- 2090228 - How to Submit Ideas for SAP SuccessFactors Products
- 2308572 - Email Notification Templates and their Target Recipients
- 2087440 - Disabling Email Notifications For One or More Users for an Instance
- 2632511 - Workflow Participant Receives two Email Notifications for the Same Workflow
- 2087890 - Top Reasons Why Email Notifications are Not Sent or Received. Basic Troubleshooting - HXM Suite
Keywords
e-mail, mail, message, note, cc, role type, cc role, dynamic, person, position, wf, approve, approval , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , LOD-SF-EC-ALR , Alerts & Notifications (saveAlert - EC Core only) , Problem