SAP Knowledge Base Article - Public

2343918 - When trying to schedule a bundle the "The Default email message has not been created" message appears on Report Distributor

Symptom

When scheduling a report bundle using the Report Distributor an error message displays after you press save "the Default Email Message has not been created."

2343918 error.jpg

Environment

  • SAP SuccessFactors Workforce Analytics
  • SAP SuccessFactors HCM Suite
  • Report Distributor
  • Report Canvas
  • Online Report Designer (ORD)
  • Advanced reporting

Reproducing the Issue

  1. Select Analytics
  2. Connect to Online Report Designer
  3. Report Distributor
  4. Create a new bundle
  5. When saving, the following error appear: The Default email message has not been created

Cause

The Default email message has not been created. This is required because a bundle being sent by email must contain an email message and it cannot be blank. Therefore, by creating a default email message, any new report bundle that is sent by email will be attached to this email message (unless a custom email message is created).

Resolution

  1. Select Analytics tab and sub tab to access the Report Distributor
  2. Navigate to Menu section, which is located at left side panel of Report Distributor - Bundle display
  3. Click on the drop down list and you will find the Edit email option
    2019-02-15_17-22-07.png

  4. Configure a default "email".
    2019-02-15_17-21-39.png

Note: If you are using the report center the navigation is:

  1. Access the Report Center
  2. Go to view Schedules 
  3. Go to Legacy Report Distributor
  4. You can perform the same steps as per above

2343918 edit email.jpg

Keywords

ORD Recipient Schedule e-mail Implement Config , KBA , LOD-SF-ANA-RDT , Report Distributor (Advanced Reporting, ORD) , LOD-SF-ANA-ORD , Online Report Designer , LOD-SF-ANA-ADV , Advanced Reporting (ODS) , Problem

Product

SAP SuccessFactors HCM Suite all versions ; SAP SuccessFactors Workforce Analytics all versions