SAP Knowledge Base Article - Public

2322721 - How to create tickets for non-active employees

Symptom

You are replicating employees in status Non-Active (eg Retired) from Employee Central to C4C and want to create tickets in C4C for those non-active employees.

However, C4C treats Non-Active employees as Inactive and it's not possible to create tickets for them.

 

 

 

Cause

C4C treats the status Non-Active as Inactive since there is no standard status other than Active and Inactive.

Non-Active is for example Retired, from the HR point of view.

Inactive in C4C is technically not active, in the sense that it’s not a valid record which should not be used.

Resolution

To enable service tickets to be created for inactive employees, following is the proposal to be implemented via custom development using SAP Cloud Application Studio.

1. The idea is to add an extension field like “CommonValidTo” to the Employee BO.

2. Please write PDI coding in Employee.BeforeSave, as seen below. 

If EmployeeType.ValidTo < 31.121999
Common. CommonValidTo = EmployeeTypeValidTo
EmployeeTypeValidTo=31.121999
Endif.

Keywords

KBA , SRD-CC , Cross Components , How To

Product

SAP Cloud for Customer core applications 1708 ; SAP Cloud for Customer core applications 1711 ; SAP Hybris Cloud for Customer add-ins 1708 ; SAP Hybris Cloud for Customer add-ins 1711