Symptom
After changing the Name Format assigned to a Legal Entity, it is not propagated to Formal Name field in employee's Personal Information.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
After changing the name format assigned to a Legal Entity:
- Go to Admin Center > Manage Data;
- Search for Legal Entity and select the desired Legal Entity;
- Select Take Action > Make Correction;
- Change the Name Format assigned:
After changing the Name Format assigned to the Legal Entity, employees in the Legal Entity do not have their Formal Name updated to the new format:
- Navigate to the Personal Information of an employee in that Legal Entity;
- View that the Formal Name has not updated to the new Name Format:
Cause
If the Name Format is updated on the Legal Entity, then it must be manually changed in the Employee’s Personal Information, for existing employees.
Resolution
- Select an impacted employee,
- Edit their Personal Information,
- Remove the Formal Name maintained, leaving the field empty and save:
- After saving or approving workflows if configured, the Formal Name field will be updated automatically with the new selected Name Format:
See Also
Keywords
Name Format, formal-name, Employee Central, EC, People Search, Search, PP3, People Profile, v12, Revolution, Public Profile, Org Chart, Formal Name, Dynamic, Refresh, Update, New Name Format, Update Name Format, Legal Entity, Change, Not Replicating, Reflecting, Personal Information, Outdated, Sync , KBA , LOD-SF-EC-PER-PRS , Personal Info - Config, Rules, RBP, UI , LOD-SF-EC , Employee Central , LOD-SF-EC-MDF , MDF & EC2MDF Migration , LOD-SF-EC-PER , Person Data (All Person Data Types) , Problem