SAP Knowledge Base Article - Public

2247074 - No stored procedures listed in Crystal Reports when connecting to Salesforce.com

Symptom

  • Stored procedures missing.
  • No stored procedures listed in Crystal Reports 2013 when connecting to Salesforce.com.
  • In Crystal Reports 2011, when connecting to Salesforce.com, the Stored Procedure are listed.
          
           
  • Note: Images and data in this SAP Knowledge Base Article is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP Crystal Reports 2013
         
  • Salesforce.com

Reproducing the Issue

  1. In Salesforce.com, create a large number of reports.
  2. Open Crystal Reports 2013, ensure you have the Database Options set to displays tables and stored procedures.
  3. Create a new report off a Salesforce.com connection.
  4. Notice there is no Stored Procedure folder listed in the "Database Expert"
      
    A - SForce - SP - 02.png

Cause

  • This situation only occurs when there is more than 2,000 Salesforce.com Stored Procedure.
  • The Salesforce.com ODBC driver can only display up to 2,000 stored procedure, and if there is more, it then fails to fetch any stored procedures.
  • This issue has been reproduced at SAP, and tracked under SAP Note 2129642

Resolution

  • The issue is resolved in the following product updates:
              
    • Crystal Reports 2013:
      • Support Pack 05 - Patch 4
      • Support Pack 06 and above

Keywords

SForce, SFDC, CR, Stored Procedure , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Bug Filed

Product

SAP Crystal Reports 2013