SAP Knowledge Base Article - Public

2245497 - External to Internal candidate conversion Job - Possible Logs and Errors - Recruiting Management

Symptom

After configuring the External to Internal Candidate Profile conversion, see more details 2249476, the back end job runs and shows a complete list of problems during the conversion.

The job log has been enhanced to provide more details for each conversion failure.

This example shows the job tried to convert two candidates, however, both failed. The log will present the detailed reason for each failure and you can check this article for some tips on how to handle each scenario.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

 conversion job logs2.jpg

This article will explain the possible reasons that lead to this problem.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

After configuring the External to Internal Candidate Profile feature, once running the quartz job for "External to Internal Candidate Profile Conversion" the recipients specified in the scheduled job receive an e-mail with the job details showing the conversion logs.

Cause

The cause of the failure may vary, the resolution section will present the most common reasons.

Resolution

1. Error: Internal Profile for matched username:USERNAME already exists with active Job Applications!

Cause: If the Employee uses the newly created internal candidate profile to apply to a job requisition before the conversion happens, the job will not convert this candidate in order to retain application data.

Suggestion: The conversion is not possible. You can merge the external and internal candidate profile using the Manage Duplicate Candidate tool.

2. Error: The external candidate could not be converted. The employee profile for {EMPLOYE_NAME} was created on {DATE}, which is before the hire date {DATE} on the application.

Cause: The employee profile was created before the candidate is hired.

Note:

  • System will consider the hired date the date when the application is moved to Hired status. If the application is placed multiple times in the hired status, it will pick the latest date.
  • If you are trying to rehire a candidate, make sure the old employee profile was deconverted. If the employee profile was not deconverted and the candidate is using a new external candidate profile, the conversion will not work.

Suggestion:

  • The conversion is not possible. You can merge the external and internal candidate profile using the Manage Duplicate Candidate tool;
  • If employee was created before hiring the candidate, and it is not a REHIRE, the customer needs to inactivate this employee and create a new one. If this option is not possible, the customer can merge the internal and external candidate profile.

3. Error: No career tab permission given to matched username: {username}.

Cause: The employee is required Career tab permission to have internal candidate profile.

Suggestion: Update Role Based Permission and add Career tab permission to new employee's role in the system.

4. Error: the employee profile is inactive.

Cause: Employee needs to be active in the system to convert the candidate profile.

Suggestion: Update user status as active in User Data File or Reset User Account.

5. Error: The hired external candidate has no matches with an employee profile. The matching field {MATCH_CRITERIA} on the candidate profile is empty.

Cause: The match criteria (conversion rule) on candidate profile is empty;

Note:

  • If the customer is not using the standard integration, it is their responsibility to have a process to fill/update this information on candidate profile.
  • If they are using all the standard components, the missing info on candidate profile may indicate a defect or gap in the implementation;

Suggestion: The candidate profile needs to be updated, the field used in the match criteria needs to be filled;

6. Error: There is no match on the candidate profile field ({0} - {1}) with employee profile.

Cause: On this case, the match criteria is empty on Employee Profile.

Note:

  • If the customer is not using the standard integration, it is their responsibility to have a process to fill/update this information on Employee profile. 

Suggestion: The Employee profile needs to be updated, the field used in the match criteria needs to be filled;

How to check match criteria:

Check the configuration in Manage Recruiting Settings

match criteria.png

For candidate profile, you can use ad-hoc or Integration center

For employee information, download the UDF and check the correspondent field

emp.jpg

Note:

When using Standard integration with Employee ID as a match criteria, you can check the employee id directly in candidate profile or retrieve the information using SFAPI.

The field updated by the integration standard integrations (EC,ONB,HCM) is the extCandUserId, this is the field you can report on SFAPI.

The example below shows the Employee Id populated in the candidate profile. If you open the candidate history information (right image) you will see an update in the field extCandUserId with the employee id information. This is the field updated by the standard integration (Onboardind, EC, HCM On Premise) and this is replicated to the Employee ID.

cand history.jpg

Final consideration for the Customers using RCM, Onboarding and SAP HCM integration or using just RCM and Onboarding integration.

For the customers that have these integrations in place we have a specific situation, the ONB OnStartDate (see details 2525342) job runs on a nightly basis and exports the UDF of the newly hired employee in BizX. Once the job completes, it sends some data back to RCM and move the candidate from a Hirable status to a Hired status, if the customer has only a Hired status, it will move the candidate again to the Hired status. This action causes the Employee Profile to be created before the candidate is moved to the hired status because the system will use as a hired date the latest date what will lead to the error "The external candidate could not be converted. The employee profile for {EMPLOYE_NAME} was created on {DATE}, which is before the hire date {DATE} on the application.".

    • Since the candidate conversion was deployed even before the implementation of Onboarding and HCM integration, this scenario was not covered by Product Management team. To accommodate the conversion along with the integrations, the product was enhanced and once enabling the option Provisioning > Company Settings > Enable Pre-Day1 Experience for new hires, the system will not take in consideration the prerequisite of Hire Date being older than the employee profile creation;
    • Enabling Pre-Day1 Experience causes behavior changes in Onboarding, if you want to start using this feature in order to fix the No Match Found for candidate conversion, you can contact SAP Product Support to discuss this change;

See Also

2249476 - External to Internal Candidate Profile conversion - Recruiting Management

2081409 - Candidate to Employee Conversion - Recruiting

2266994 - How Employee to Candidate Conversion works? (FAQ)

2648209 - External to Internal Candidate Conversion Failing - Recruiting Management

Keywords

External to Internal Candidate Profile Conversion, Candidate Profile Conversion, Candidate Conversion, Recruiting, Success Factors, No match found, OnStartDate, RCM-44361 , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , Problem

Product

SAP SuccessFactors Recruiting all versions