SAP Knowledge Base Article - Public

2204887 - Error: 'HY000:API_DISABLED_FOR_ORG: API is not enabled for this Organization or Partner', when attempting to connect to Salesforce.com from Crystal Reports

Symptom

  • Unable to connect to Salesforce.com
  • Error: 'HY000:API_DISABLED_FOR_ORG: API is not enabled for this Organization or Partner'
  • When attempting to logon to Salesforce.com from Crystal Reports 2013, it fails with the error:
          
       "Database Connector Error: 'HY000:API_DISABLED_FOR_ORG:
        API is not enabled for this Organization or Partner' "
          
  • Can successfully connect to Salesforce.com from Crystal Reports 2011 and below.
      
        
  • Note: Images and data in this SAP Knowledge Base Article is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP Crystal Reports 2013
  • SAP Crystal Reports 2016
        
  • Salesforce.com

Reproducing the Issue

  1. In Crystal Reports, create a new report, and select the connection: Salesforce.com
  2. After entering the Salesforce.com user name and password, it fails with the error:
       
       "Database Connector Error: 'HY000:API_DISABLED_FOR_ORG:
        API is not enabled for this Organization or Partner' "
        
         
    Sforce API Error.png

Cause

  • This error occur because of the limitation of the Edition of Salesforce.com used.

    The following Salesforce.com Edition does not have access to API, which is what the driver needs to connect to Salesforce.com:
     - Contact Edition
     - Group Edition
     - Professional Edition

    And the Saleforce.com ODBC driver that is now bundle in Crystal Reports 2013, is not fully certified yet. Once it is cerified, Salesforce.com will allow a Professional Edition of Salesforce.com to access the API, even if this Edition does not have access to the API.

    In Crystal Reports 2011 and below, Crystal Reports was using a different driver, which was certified by Salesforce.com, and therefore this is why it is possible to connect successfully to Salesforce.com

  • This situation has been tracked under SAP Note 2204966

Resolution

  • The third party Salesforce.com ODBC driver has now been certified by Salesforce.com, therefore, it is now possible to connect with a Salesforce.com Professional Edition in the following version of Crystal Reports:
           
    • Crystal Reports 2013:
      • Support Pack 05 - Patch 10
      • Support Pack 06 - Patch 3
      • Support Pack 07 and above
           
                  
  • Note: If you cannot apply an update to Crystal Reports 2013 at this point, then there is unfortunately no workaround, other than using a Salesforce.com Edition that have access to API, like:
    - Enterprise Edition
    - Unlimited Edition
    - Developer Edition
    - Performance Edition
       
    Or, to use Crystal Reports 2011 or below.

Keywords

CR, SForce, Salesforce API error , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem

Product

SAP Crystal Reports 2013 ; SAP Crystal Reports 2016