SAP Knowledge Base Article - Public

2157796 - Object Reference not set to an Instance of an Object - Onboarding

Symptom

  • Error displayed throughout all pages in Employee Portal
  • Object reference not set to an instance of an object
  • Credentials are not added in Employee Portal

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Onboarding

Cause

Web service credentials not added in Employee Portal, causing below error:

cause.PNG

Resolution

  1. Check the web service credentials and URL configuration in EP. They need to be created/added.
  2. Go to Site Actions-> App Settings, check for keys : WSLogin, WSPassword and WSUrl.
  3. WSLogin : Should be the following format. {instancename}_eeportal.
  4.  WSPassword: Should match the password of servicelogin {instancename}_eeportal - (Go to superadmin site-> Account->Servicelogins to get the password.)
  5. WSUrl: {application URL till partner}/services/EmployeePortalService.asmx

Example: https://stage-onboarding4.successfactors.com/ONB/services/EmployeePortalService.asmx

      Add item OBJ REF.jpg

Keywords

Error, Object reference, ONB, OBD, employee, portal, sf, success factors , KBA , LOD-SF-OBD-EP , Portal , LOD-SF-OBD , Onboarding , Problem

Product

SAP SuccessFactors Onboarding all versions