SAP Knowledge Base Article - Public

2086663 - The Iterative Step in a Route Map is Missing a User in Performance Management

Symptom

There is a user missing from the Iterative step in a route map for a Performance Review.

Environment

SAP SuccessFactors Performance Management

Reproducing the Issue

  1. Log into the instance
  2. Go to the PM module
  3. Open a PM form
  4. Notice there's a user missing in the Iterative Step, although he/she is configured in the Route Map 

Cause

  • The user was inactive in the system at the time the form was created or routed. The SuccessFactors Application will automatically skip any inactive user in a route map at the time the route map is created, during a manager change, or when routing, so while an employee may be set as active today, at the time of the routing they were inactive and therefore skipped in the current route map.
  • Permissions, RBP Permissions: Make sure the user has been granted all required permissions to access the system. If they lack permissions to login then the system is intelligent enough to know this and will therefore skip that user to prevent the form from becoming stuck with someone that can't access it.
  • A new manager was hired into the system via the user data import and the system saw the new manager as inactive because the employee came before the new manager in the order of the employee import.

Resolution

Use Route Form to route it back 1 step. This causes the system to re-evaluate employee data, new managers, route steps, and roles. The form will be refreshed to reflect the current state of all these variables. You can follow the steps in Implementing and Managing Performance Management - Routing an Individual Form.

See Also

KB article 2087316 - Skip the Route Map Step is a User is Missing in Performance Manager

Keywords

sf, success factors, PMGM, PM, document routing, form, performance review , KBA , LOD-SF-PM-MAP , Routing, Route Maps & Workflows , Problem

Product

SAP SuccessFactors Performance & Goals all versions