SAP Knowledge Base Article - Public

2076003 - Your request has not been processed successfully. Error 900-001-6 - Performance Management

Symptom

When trying to open a form, launch a form, route a form, sign a form, reject a form, etc., the following error is received:

Your request has not been processed successfully. Please try again. If the problem persists, please contact client support and provide the event code and the server timestamp below. 900-001-6 Mon Aug 23 15:04:01 EDT 2010 Release 10 build (b1007p5erc2) - 35/dc4sfapp05cCluster06-405

Note: This is a general error code and could be caused by issues other than those listed below.

Environment

SAP SuccessFactors Performance & Goals

Cause

This is a general error code, it can be caused by many issues including conditions on the servers or network.

  • Transient Server issue (comes & goes)
  • Transient Network issue (comes & goes)
  • Invalid competency ID in form - error is consistent, the form will usually not open
  • Number of competencies in the form exceeded the limit - current limit is 1,000 
  • Invalid participant/user in the route map, error is consistent, the form will not be able to be routed to the next/previous step
  • The user is not in the Default User Group
  • User does not have the permission to the goal/objective/development plans referenced in the form - see KBA 2227842 
  • If using OOTA (Out of Turn Access) check: The Out of Turn Access should not be enabled for 1:1 meeting step
  • When using Gap Analysis Button please see KBA 2075910
  • When trying to launch a form - see KBA 2075973 
  • This error message might also appear in case the limitation for an email notification title is larger than 200 bytes. So if an email title is too long, the error message will appear, e.g. when routing a PM form.
  • This error message might also appear when the goal plan field was removed from the goal template, but it remained in the form-layout configuration of the goal plan - see KBA 2172251 

Resolution

Transient issues may be resolved if you try again later. Support will not be able to investigate this error when it only happens to 1 or a few people briefly and is no longer happening. 

If the error is not temporary, please check the following:

  • The competency IDs hardcoded on the forms and ensure these exist in your competency library
    • This can happen when you copy a template from test to production or if a competency has been deleted
    • It is recommended that competencies not be deleted
  • Other common causes are bad data added by users pasting text into their form - see KBA 2076009
  • Bad goal data - see KBA 2076009
  • Inactive or invalid users in the workflow. (This usually can be corrected by routing the form using the Route Form tool in Admin Center)
  • Limit the number of competencies to less than the limit of 1,000 
  • If using OOTA, it should not be enabled for a 1:1 meeting step. If the step is a 1:1 type, disable OOTA for this step & retest.
  • Ensure the user has the correct permission to access objective/goal/development plans referenced in the PM form - see KBA 2227842
  • If the form has Goal/Objective section or Development Goal section, make sure the Goal Management Suite is enabled in Provisioning
  • Check if all fields in form-layout configuration of the goal plan are defined in field-definition of the relevant goal plan xml

Note: If the cause of the error can not be determined, a support case can be opened with SuccessFactors Product Support for further investigation

See Also

  • KB article 2076009 - Form Won't Open, Route, Looks Cut Off, or is Strangely Formatted
  • KB article 2075973 - Error - 900-001-6 error when trying to create a form

Keywords

SF, SuccessFactors, PM, GM, PM Form, 900-001-6, error,  intermittent 900 PM v12A, v12 a, PMU-2600 , KBA , LOD-SF-PM-SYS , System Performance , LOD-SF-PLT , Platform Foundational Capabilities , LOD-SF-CMP , Compensation Management , Problem

Product

SAP SuccessFactors HCM all versions ; SAP SuccessFactors Performance & Goals all versions