SAP Knowledge Base Article - Public

2057712 - Service Items are not Copied from a Contract to a Sales Order

Symptom

  • You create a Sales Order as a ollow-up from a Contract or by using Create with Reference.
  • The system automatically copies the general data such as Account ID however the item data such as Product ID and Price Agreement are not copied from the contract to the sales order.
  • Error messages are raised for each item:

Copying item XX not possible; configuration from Service - time and material to Service - time and material missing 
Or
Copying item XX not possible; configuration from Service - fixed price to Service - fixed price missing

(XX represents the line item number)

Environment

SAP Business ByDesign

Reproducing the Issue

Create with Reference Scenario:

  1. Go to the Sales Orders work center.
  2. Select New Sales Order from the Common Tasks.
  3. Click the Create with Reference button and select in the Reference Type field Contract.
  4. Select the Value Help for the Reference ID field.
  5. You cannot see any contracts with service items.
  6. Enter reference id XYZ manually (XYZ represents the id of the contract).
  7. Click on the Enter button.
  8. You can see that the general data is taken over but the items are not and the following warning messages are displayed:

    Copying item XX not possible; configuration from Service - fixed price to Service - fixed price missing
    Or
    Copying item XX not possible; configuration from Service - time and material to Service - time and material missing

Follow-Up Scenario:

  1. Go to the Sales Orders work center.
  2. Select the Contract view.
  3. Search for and select Contract ABC (ABC stands for the contract ID).
  4. Click Follow-up and choose Sales Order.
  5. Error messages are raised on the New Sales Order screen:

    Copying item XX not possible; configuration from Service - fixed price to Service - fixed price missing
    Or
    Copying item XX not possible; configuration from Service - time and material to Service - time and material missing

Cause

Currently creating a sales order with reference to a contract for service items is not supported.

For contracts with service items, the corresponding follow up document can only be service confirmations.

Resolution

This is the current system behaviour.

Keywords

contract, sales order, service items, follow up, create with reference, cannot create, fixed price to Service, time and material to Service, missing, error message, contrat, services , KBA , AP-SLO , Sales Order Processing , How To

Product

SAP Business ByDesign 2211 ; SAP Business ByDesign 2302 ; SAP Business ByDesign 2305