Symptom
- Cannot open or create a report based off a BEx Query in Crystal Reports using the SAP toolbar.
- When attempting to open a report, and attempting to login to SAP BW from Crystal Reports, it fails with the error:
'Failed to retrieve SSO2 logon ticket, please contact BW administrator.'
Environment
- SAP Crystal Reports 2008
- SAP Crystal Reports 2011
- SAP Crystal Reports 2013
- SAP Crystal Reports 2016
- SAP BW 3.5
- SAP BW 7.1 and above
Reproducing the Issue
- In Crystal Reports, under the menu "SAP", select "Create new report from a query..."
- Select an SAP BW System. It then fails with the error:
'Failed to retrieve SSO2 logon ticket, please contact BW administrator.'
Cause
- SSO ticket generation is not enabled on the SAP BW System, which is required when connecting to SAP BW from Crystal Reports SAP Toolbar, if you are using SSO.
Resolution
- Turn on the SAP SSO ticket generation by following the steps below:
Important Note:
- The following steps should be performed by the SAP BASIS Administrator. The following is for informational purposes only.
- Enter transaction rz10 in SAP GUI, profile: DEFAULT
- Check "Extended Maintenance" and click "Change"
- Add the following Parameters and their corresponding value:
- Parameter Name: Parameter value
- login/accept_sso2_ticket 1
- login/create_sso2_ticket 2
- Restart the SAP BW server.
See Also
See note 1413075
Keywords
CR, SAP BW, BEX queries , KBA , BI-BIP-AUT , Authentication, ActiveDirectory, LDAP, SSO, Vintela , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem
Product
Crystal Reports 2008 V1 ; SAP Crystal Reports 2011 ; SAP Crystal Reports 2013 ; SAP Crystal Reports 2016