SAP Knowledge Base Article - Public

1206543 - Salesforce.com not listed in available datasources in Crystal Reports

Symptom

  • Salesforce.com option not available
  • When attempting to create a new report in Crystal Reports,  the Salesforce.com connection type is not listed in the available datasources.
      
        
  • Note: Images and data in this SAP Knowledge Base Article is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP Crystal Reports 2011
  • SAP Crystal Reports 2013
  • SAP Crystal Reports 2016

Reproducing the Issue

  1. In Crystal Reports, create a new report.
  2. In the "Database Expert" window, under "Available Data Sources", the Salesforce.com connection is missing
      
    Sforce - Missing.png

Cause

  • The Salesforce.com driver is not installed.
  • By default, the Salesforce.com driver is installed when installing Crystal Reports, but if the software was installed using a custom installation, then it is possible to select to not install it.

Resolution

  • To install the Salesforce.com driver for Crystal Reports:
        
    1. On the computer where Crystal Report is installed, go to the MS Windows Control Panel, and select "Programs and Features"
    2. In the "Programs and Features" window, select the application: "SAP Crystal Reports", and click "Uninstall/Change"
    3. In the "SAP Crystal Reports setup" window, select "Modify" and click "Next"
    4. In the screen: "Select Language Packages", click "Next"
    5. In the screen "Select Features", under "Database Access", check the option "Salesforce.com Driver", and click "Next"
          
        Sforce - Missing - 02.png
        

      It will now install the Salesforce.com driver.

Keywords

Sforce, missing, CR , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem

Product

Crystal Reports 2008 V1 ; SAP Crystal Reports 2011 ; SAP Crystal Reports 2013 ; SAP Crystal Reports 2016