SAP Knowledge Base Article - Preview

2901520 - My Inbox - Text "Loading" is shown and incorrect attachment count on header/toolbar icon

Symptom

  • Using an FLP@EP implementation
  • Upgraded My Inbox component to 1.23.8 as delivered in software UIBAS001 500
  • When the users click on the "attachments" tab on any task, the text "Loading" is shown even when there are no attachments available and the count (1/1) is shown instead of (0/0)
  • However, if we add an attachment and save it then it works fine and displays the actual number and the attachment saved before
  • This behavior is observed on both IE and Chrome as well and in both Normal and Expert mode of My Inbox
  • Example of issue:

    ~~~~~~~~~~Start Here~~~~~~~~~~~~~~

    The count of the header attachment icon claims there is 1 attached file.

     ~~~~~~~~~~~start Screen~~~~~~~~~~~

    Where X is the currently selected item or has focus

    ---------------------------------------------------------------------------------------------------------------------
    |Task List  |  Header icon Info X | Notes (1) | Attachment (1) | Link (1) | <-- check attach count
    ----------------------------------------------------------------------------------------------------------------------

    |Task 1 X  |
    |Task 2     | Details of Task 1 under the Info tab
    |Task 3     | .........................

     

    ~~~~~~~~~~~end Screen~~~~~~~~~~~~~~

     

    When the user clicks on the Attachment icon (1 count) to check what is inside it, the layout of the screen changes:

    ~~~~~~~~~~~start screen~~~~~~~~~~~~~~~~~~~~


    Where X below is the currently selected task or where the user clicked.

    -------------------------------------------------------------------------------------------------
    |Task List |   Header icon Info | Notes (1) | Attachment (0) X | Link |
    -------------------------------------------------------------------------------------------------

    |Task 1 X |
    |Task 2    | Attachment (1/1) <-- The attachment still states 1 but the Header Icon resets to 0 above
    |Task 3    |
                                                           ---------
                                                           |         |
                                                           |         |
                                                           |         |
                                                           ---------
                                                          Loading...
                                    Drop files to upload or use the "+" button.

    ~~~~~~~~~~~~end screen~~~~~~~~~~~~~~~~~~~

     

    the Attachment icon resets to (0 attachment) but the

    Loading text "Loading..." is shown with the text: Drop files to upload or use the "+" button.


Read more...

Environment

  • My Inbox 1.23.8
  • UIBAS0001 SP500 (June to September 2019 release date) 

Product

SAP NetWeaver 7.5

Keywords

"My Inbox Attachment","My Inbox Attachment count","My Inbox wrong count","My Inbox counter shows 1","My Inbox attachment count should be zero","My Inbox has no attachment","My Inbox Toolbar header count","My Inbox Task Attachment" , KBA , OPU-GW-COR , Framework , CA-INB-FIO , Fiori UI for My Inbox Application , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.