SAP Knowledge Base Article - Preview

2678262 - Adapter start with security errors after JRE 8.1 upgrade - Data Services

Symptom

  •  Upgrade to JRE 8.1 and copy files over from the JRE 6.1 folder.
  •  On starting the Adapters the following error may appear.
    Error "java.lang.ExceptionInInitializerError at javax.crypto.JceSecurityManager.<clinit>(JceSecurityManager.java:65)
    Caused by: java.lang.SecurityException: Can not initialize cryptographic mechanism at javax.crypto.JceSecurity.<clinit>(JceSecurity.java:93)
    Caused by: java.lang.SecurityException: The jurisdiction policy files are not signed by the expected signer! (Policy files are specific per major JDK release.Ensure the correct version is installed.)"

Read more...

Environment

SAP Data Services

Product

SAP Data Services 4.2

Keywords

KBA , EIM-DS , Data Services (Use Subcomponent) , EIM-DS-EXE , Data Services Job Execution , How To

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.