SAP Knowledge Base Article - Preview

2670414 - Error "java.lang.UnsupportedClassVersionError" during installing NW7.4/SolMan 7.2 AS Java with Hana 2.0

Symptom

During installing AS Java system of Solution Manager 7.2 or Netweaver 7.4, the step Execution of JLoad tool fails with below error message:

----------------------------------------------------------

ERROR      2018-07-12 17:22:56.243 (PROD\VanBlerk-Admin) (startInstallation) [CSiStepExecute.cpp:1102] id=controller.stepExecuted errno=FCO-00011 CSiStepExecute::execute()
The step importJavaDump with step key |NW_Java_OneHost|ind|ind|ind|ind|0|0|NW_Onehost_System|ind|ind|ind|ind|onehost|0|NW_CreateDBandLoad|ind|ind|ind|ind|createdbandload|0|nw_java_import|ind|ind|ind|ind|javaimport|0|NW_Jload|ind|ind|ind|ind|jload|0|importJavaDump was executed with status ERROR (Last error reported by the step: <html> <head> </head> <body> Execution of <code>JLoad</code> tool '"C:\Program Files\sapinst_instdir\SOLMAN72SR1\SOLMAN72SR1\HDB\INSTALL\STD\sapjvm\sapjvm_6\bin\java.exe" -classpath "C:\Program Files\sapinst_instdir\SOLMAN72SR1\SOLMAN72SR1\HDB\INSTALL\STD\install\lib\sap.com~tc~bl~offline_launcher~impl.jar" -showversion -Xmx512m -XX:+HeapDumpOnOutOfMemoryError com.sap.engine.offline.OfflineToolStart com.sap.inst.jload.Jload "\\xxxxxx/sapmnt/SID/SYS/global/security/lib/tools/iaik_jce.jar; \\xxxxxx/sapmnt/SID/SYS/global/security/lib/tools/iaik_jsse.jar; \\xxxxxx/sapmnt/SID/SYS/global/security/lib/tools/iaik_smime.jar; \\xxxxxx/sapmnt/SID/SYS/global/security/lib/tools/iaik_ssl.jar; \\xxxxxx/sapmnt/SID/SYS/global/security/lib/tools/w3c_http.jar; C:/Program Files/sapinst_instdir/SOLMAN72SR1/SOLMAN72SR1/HDB/INSTALL/STD/install/lib;E:/usr/sap/SID\hdbclient\ngdbc.jar" -sec SID,jdbc/pool/SID,\\xxxxxx/sapmnt/SID/SYS/global/security/data/SecStore.properties,\\xxxxxx/sapmnt/SID/SYS/global/security/data/SecStore.key -dataDir F:\Media\51050949_JAVA_Export_SR1\DATA_UNITS\JAVA_EXPORT_JDMP -job "C:\Program Files\sapinst_instdir\SOLMAN72SR1\SOLMAN72SR1\HDB\INSTALL\STD\IMPORT.XML" -log jload.log' aborts with return code 2.<br>SOLUTION: Check 'jload.log' and 'C:/Program Files/sapinst_instdir/SOLMAN72SR1/SOLMAN72SR1/HDB/INSTALL/STD/jload.java.log' for more information. </body></html>).

----------------------------------------------------------

checking jload.java.log

----------------------------------------------------------

Jload -sec SID,jdbc/pool/SID,\\xxxxxx/sapmnt/SID/SYS/global/security/data/SecStore.properties,\\xxxxxx/sapmnt/SID/SYS/global/security/data/SecStore.key -dataDir F:\Media\JAVA_EXP_51050819\DATA_UNITS\JAVA_EXPORT_JDMP -job C:\Program Files\sapinst_instdir\NW740SR2\HDB\INSTALL\STD\IMPORT.XML -log jload.log
Connecting to database
  FATAL: Main class "com.sap.inst.jload.Jload" cannot be started:
  FATAL: java.lang.UnsupportedClassVersionError: com/sap/db/jdbc/Driver has been compiled by a more recent version of the Java Runtime (class file version 51.0), this version of the Java Runtime only recognizes class file versions up to 50.0

----------------------------------------------------------


Read more...

Environment

NW 7.4, Solution Manager 7.2, Hana 2.0

Product

SAP NetWeaver 7.4 ; SAP Solution Manager 7.2

Keywords

Execution of JLoad tool, return code 2,jload.log, jload.java.log,java.lang.UnsupportedClassVersionError, com/sap/db/jdbc/Driver has been compiled by a more recent version of the Java Runtime, class file version 51.0, this version of the Java Runtime only recognizes class file versions up to 50.0, SWPM, Solution Manager 72, NW 7.4, Hana 2.0 , KBA , BC-INS-SWPM , Installation with Software Provisioning Manager , HAN-DB-CLI , SAP HANA Clients (JDBC, ODBC) , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.