SAP Knowledge Base Article - Preview

2657177 - upgrade to 16.0.03.04 aborts with error - SAP ASE for BS

Symptom

  • You are upgrading to SAP ASE 16SP03PLxx using saphostctrl and SAP Note: 1982469
  • upgrade aborts with error: "Installed version (15.7.0.135000) is older than the minimum version (16.0.0.0) to do update."
  • /usr/sap/hostctrl/exe/saphostctrl -user sapadm XXXXXXXX -function LiveDatabaseUpdate -dbname SID -dbtype syb -updatemethod Execute -updateoption TASK=UPDATE_ASE -updateoption DROP_LOCATION="/DROP_DIR/ASE/160304/SERVER/SID"
    Error: Command execution failed. : command /bin/sh -c "/DROP_DIR/ASE/160304/SERVER/SID/setup.bin -f /usr/sap/hostctrl/work/SID/dbsrvresp_update.txt -i silent -DAGREE_TO_SAP_LICENSE=true -DAGREE_TO_SYBASE_LICENSE=true -DUSER_INSTALL_DIR=/sybase/SID 2>&1 ": failed with exit code 255. (fault code: 127)

    ----- Response data ----
    ERROR: command /bin/sh -c "/DROP_DIR/ASE/160304/SERVER/SID/setup.bin -f /usr/sap/hostctrl/work/SID/dbsrvresp_update.txt -i silent -DAGREE_TO_SAP_LICENSE=true -DAGREE_TO_SYBASE_LICENSE=true -DUSER_INSTALL_DIR=/sybase/SID 2>&1 ": failed with exit code 255.
    Update install not available. You can only do update install from SAP Adaptive Server Enterprise version 16.0 GA or newer. Rerun installer with "DO_UPDATE_INSTALL=false".
     
    ----- Log messages ----
    Info: saphostcontrol: Executing LiveDatabaseUpdate
    Error: sapdbctrl: command /bin/sh -c "/DROP_DIR/ASE/160304/SERVER/SID/setup.bin -f /usr/sap/hostctrl/work/SID/dbsrvresp_update.txt -i silent -DAGREE_TO_SAP_LICENSE=true -DAGREE_TO_SYBASE_LICENSE=true -DUSER_INSTALL_DIR=/sybase/SID 2>&1 ": failed with exit code 255.
    Error: saphostcontrol: LiveDatabaseUpdate failed (sapdbctrl exit code = 1)


Read more...

Environment

  • SAP Adaptive Server Enterprise (ASE) 15.7 for Business Suite
  • SAP Adaptive Server Enterprise (ASE) 16.0 for Business Suite
  • SAP Enterprise Resource Planning (ERP) 6.0
  • SAP Customer Relationship Management (CRM) 7.0
  • SAP Supplier Relationship Management (SRM) 7.0
  • SAP Supply Chain Management (SCM) 7.0
  • SAP Solution Manager (SOLMAN) 7.1
  • SAP NetWeaver (NW) - All versions 

Product

SAP Adaptive Server Enterprise 15.7 ; SAP Adaptive Server Enterprise 16.0 ; SAP Customer Relationship Management 7.0 ; SAP ERP 6.0 ; SAP NetWeaver all versions ; SAP Solution Manager 7.1 ; SAP Solution Manager 7.2 ; SAP Supplier Relationship Management 7.0 ; SAP Supply Chain Management 7.0

Keywords

update, upgrade, 16SP03PL04, ASE16SP03PL04 , KBA , BC-DB-SYB , SAP Business Suite on Sybase ASE Database Platform , How To

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.