SAP Knowledge Base Article - Preview

2631027 - Error "SAP HANA Smart Data Access is not compatible with SAP HANA Database version 2.00.024" while upgrading HANA

Symptom

  • You are upgrading your HANA database to SAP HANA 2.0 via HDBLCM. Your current HANA SPS12 system uses SAP HANA Smart Data Access (SDA) so you also downloaded the IMDB_SDA200_02_0-70002151.SAR file as per SAP Note 2352696. However the upgrade fails with error:

"An already installed component SAP HANA Smart Data Access is not compatible with SAP HANA Database version '2.00.024.00.1520347815'. SAP HANA Smart Data Access requires SAP HANA Database with version between 1.00.110.00 inclusive and 1.00.999.00 exclusive."

  • If you look at the HDBLCM upgrade logs you will find entries like these:

"ERR : Cannot access manifest file '/hana/shared/<SID>/global/hdb/install/manifest': No such file or directory"

"ERR : Unresolved dependency: 1.00.110.00 <= sap.com HDB < 1.00.999.00"


Read more...

Environment

SAP HANA Database 2.00.024.00.1520347815

Product

SAP HANA 1.0, platform edition ; SAP HANA, platform edition 2.0

Keywords

HANA, SDA, upgrade, HDBLCM, manifest. , KBA , HAN-LM-UPG-DB , Upgrade of HANA Database , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.