2574454 - UI Theme Designer shows a Preview Version Mismatch error | SAP Knowledge Base Article

SAP Knowledge Base Articles - preview

2574454 - UI Theme Designer shows a Preview Version Mismatch error


  • You are using the UI Theme Designer on the Enterprise Portal and have already activated the Fiori 2.0/SAPUI5 1.44 mode (KBA 2486524)
  • When you try to edit any of the SAPUI5 controls, or the Fiori Framework Page you receive an error similar to the below:
    "Preview Version Mismatch
    The minor version of SAPUI5 used in your current preview application (1.38.XX) does not match the minor version of SAPUI5 used in the theme repository (1.44.XX).

    This will most likely cause rendering issues in the UI theme designer.
    Please adjust either the SAPUI5 version of your application or the used theme repository."
  • This error will show when either editing existing theme, or creation of a new theme



  • SAP NetWeaver Application Server for Java 7.50
  • Enterprise Portal
  • SAPUI5 1.44/Fiori 2.0 design activated


SAP NetWeaver 7.5


ui5, sap, sapui5, portal, ep, java, controls, fwp, framework, page, uitd, theme, editor, motiv, flp, flp@ep, sap_belize, sap_bluecrystal, sap_goldreflection, sap_belize_deep, sap_belize_plus , KBA , EP-PIN-TOL-UTD , UI Theme Designer in Portal & new theme structure issues , EP-PIN-NAV-FFP , Fiori Framework Page , CA-UI2-THD , Theme Designer , EP-PIN-TOL , Themes / Portal UI Theme Designer / Theme Editor , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.