SAP Knowledge Base Article - Preview

2573431 - "Could not load program" returned when trying to start upgraded ASE to 16 version

Symptom

  • You are upgrading ASE version 15.5 to release 16.
  • After upgrade, the start server with new binaries 16.0 returns those messages:

$ startserver -f RUN_<dataservername>
$ Could not load program /usr/sybase/ASE-16_0/bin/dataserver:
Dependent module libsybcsi_core29_64.so could not be loaded.
Could not load module libsybcsi_core29_64.so.
System error: No such file or directory

-----------------------------------------------

$ startserver -f RUN_<dataservername>
$ Could not load program dataserver:
rtld: 0712-001 Symbol CreateIoCompletionPort was referenced
from module dataserver(), but a runtime definition
of the symbol was not found.
rtld: 0712-001 Symbol GetMultipleCompletionStatus was referenced
from module dataserver(), but a runtime definition
of the symbol was not found.
rtld: 0712-001 Symbol PostQueuedCompletionStatus was referenced
from module dataserver(), but a runtime definition
of the symbol was not found.
rtld: 0712-001 Symbol ReadFile was referenced
from module dataserver(), but a runtime definition
of the symbol was not found.
rtld: 0712-001 Symbol WriteFile was referenced
from module dataserver(), but a runtime definition
of the symbol was not found.
rtld: 0712-002 fatal error: exiting.


Read more...

Environment

  • SAP Adaptive Server Enterprise (ASE) 16.0 on AIX

Product

SAP Adaptive Server Enterprise 16.0

Keywords

IOCP, Sybase, upgrade, "Could not load module", "Could not load program", libsybcsi_core29_64 , KBA , BC-SYB-ASE , Sybase ASE Database Platform (non Business Suite) , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.