2571270 - Fiori Client 1.9 Vulnerabilties | SAP Knowledge Base Article

SAP Knowledge Base Article - Preview

2571270 - Fiori Client 1.9 Vulnerabilties

Symptom

Following vulnerabilities are detected in Fiori Client 1.9.x:

  • Application data can be backed up by attackers
  • Following Activities are not protected:
    1. com.sap.smp.client.httpc.authflows.OTPAuthActivity (An intent-filter exists)
    2. com.sap.mp.cordova.plugins.authProxy.AuthProxyOTPAuthActivity (An inent-filter exists)
  • Broadcast Receiver (com.sap.mp.cordova.plugins.authProxy.WifiChangeReceiver) is not protected. An intent-filter exists
  • Review of permisssion access for the application

Read more...

Environment

SAP Fiori Client 1.9.x

Product

SAP NetWeaver 7.5

Keywords

KBA , MOB-FC , SAP Fiori Client Native Mobile Application , Bug Filed

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.