SAP Knowledge Base Article - Preview

2569592 - hdblcmgui startup fails with "cannot load wxWidgets properly: Failed to initialize wxWidgets at sdbrun/Require.pl"

Symptom

Starting the graphical version of HDBLCM

>.hdblcmgui.sh

results in the following error:

PM: Error: Unable to initialize GTK+, is DISPLAY set properly?
SAP HANA Installer Runtime Error:
perl compilation error (loading LCM::Gui::App::LCMGuiApp):
cannot load wxWidgets properly: Failed to initialize wxWidgets at sdbrun/Require.pl line 62.
BEGIN failed--compilation aborted at SDB/Install/App/Gui.pm line 6.
BEGIN failed--compilation aborted at LCM/Gui/App/LCMGuiApp.pm line 6.


Read more...

Environment

SAP HANA, platform edition 1.0, SAP HANA, platform edition 2.0

Product

SAP HANA 1.0, platform edition ; SAP HANA, platform edition 2.0

Keywords

xserver, display, env, perl, wxWidgets , KBA , HAN-LM-INS , SAP HANA Installation , How To

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.