SAP Knowledge Base Article - Preview

2533820 - Environment variable is not a valid YAML

Symptom

SAP XSA space enablement fails with the following exception:

Compiling Java application...
SEVERE: The user provided value '[java_opts: " -Dhttp.nonProxyHosts=\\"xyz\\"
-Dhttps.nonProxyHosts=\\"xyz\\" -Dfile.encoding=UTF-8"]' for JBP_CONFIG_JAVA_OPTS environment variable is not a valid YAML.
Execution of bin/compile failed (exit value 3)
Failed to stage app 'di-builder' [Org 'xy' Space 'yz']: Execution of bin/compile failed (exit value 3).
Error staging application "di-builder": 200 Application staging failed


Read more...

Environment

SAP Web IDE for HANA

XSA

Keywords

YAML, space enablement, xsa, Web IDE, space, HANA, di-builder, MTA, , KBA , HAN-WDE-INS , Installation SAP Web IDE for HANA , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.