2517852 - Projects do not start - SAP Event Stream Processor | SAP Knowledge Base Article

SAP Knowledge Base Article - Preview

2517852 - Projects do not start - SAP Event Stream Processor

Symptom

  • SAP Event Stream Processor is installed and running, using multiple nodes in the cluster.
  • Projects that used to load and start without problems, have begun to not start, since starting to use multi-node cluster.
  • The log messages in esp_server.log show the problem followed immediately by a correct project start:  

2017-07-31 14:46:16.012 | 15176 | container | [SP-6-135021] (0.000) sp(5700) Platform::main() -- REVISION <5.1.122.11/20170722.1/SP12 Rev122 PL11/winnt/x86_64/64-bit/OPT/Sat, Jul 22, 2017 5:14:11 AM>, start timestamp (gmt): 07/31/2017 14:46:16
2017-07-31 14:46:16.012 | 15176 | container | [SP-6-100010] (0.000) sp(5700) ------ License check started ------
2017-07-31 14:46:16.059 | 15176 | container | [SP-6-100010] (0.047) sp(5700) ------ License check succeeded ------
2017-07-31 14:46:16.059 | 15176 | container | [SP-6-135036] (0.047) sp(5700) Platform::main() -- Starting initialization sequence.
2017-07-31 14:46:18.200 | 15176 | container | [SP-3-720035] (2.188) sp(5700) Manager.decrypt() status=[failure] faillure-code=[700287] failure=[Caught exception decrypting data]
2017-07-31 14:46:18.200 | 15176 | container | [SP-2-135001] (2.188) sp(5700) Platform::main() Could not initialize SSL layer.
2017-07-31 16:46:27.146 | 29008 | container | [SP-6-135021] (0.001) sp(30984) Platform::main() -- REVISION <5.1.122.11/20170722.1/SP12 Rev122 PL11/winnt/x86_64/64-bit/OPT/Sat, Jul 22, 2017 5:14:11 AM>, start timestamp (gmt): 07/31/2017 16:46:27
2017-07-31 16:46:27.148 | 29008 | container | [SP-6-100010] (0.002) sp(30984) ------ License check started ------
2017-07-31 16:46:27.212 | 29008 | container | [SP-6-100010] (0.067) sp(30984) ------ License check succeeded ------
2017-07-31 16:46:27.214 | 29008 | container | [SP-6-135036] (0.069) sp(30984) Platform::main() -- Starting initialization sequence.
2017-07-31 16:46:29.505 | 29008 | container | [SP-6-114126] (2.360) sp(30984) Platform(): Auto Checkpoint interval is set to 0.
2017-07-31 16:46:30.407 | 29008 | container | [SP-6-100010] (3.262) sp(30984) <asapInfo commandPort="50242" sqlPort="50243" pid="30984" />
2017-07-31 16:46:30.428 | 19864 | container | [SP-6-109005] (3.283) sp(30984) GatewayServer::GatewayServer() using passed port: 50244
...

  • When using streamingclusteradmin to do "get projects", the output shows the problem where two projects (that have a binding between them) didn't start, and then on another try did start. The project named <foo_test_db> did start on the first try, but it was stopped and restarted. It failed on the second try, and restarted again on the third try.

> get projects

=============================
Workspace: default
Project: foo_ppe_outbound
Instance Count: 1
----------- Instance Details -----------
Instance Name: default
Controller Name: host1_controller_node
Current Status: stopped
Requested Status: stopped
Failure Interval: 0
Failures Per Interval: 0
=============================
Workspace: default
Project: foo_test_db
Instance Count: 1
----------- Instance Details -----------
Instance Name: default
Controller Name: host1_controller_node
Current Status: stopped
Requested Status: stopped
Failure Interval: 0
Failures Per Interval: 0

> start project default/foo_ppe_outbound

[error] server returned : [FAILURE:Application wait for status is started, but application current status is not started.][CODE:710096]
> start project default/foo_ppe_outbound

[done]
> start project default/foo_test_db

[done]
> stop project default/foo_test_db 200

[done]
> start project default/foo_test_db

[error] server returned : [FAILURE:Application wait for status is started, but application current status is not started.][CODE:710096]
> start project default/foo_test_db

[done]
>

  • The same problem occurs in Studio, but when the project finally starts, it is disconnected from the Studio perspective. Selecting the "Connect to Project" menu option does not work, ie, Studio has to be restarted before it can connect to the project.

Read more...

Environment

SAP Event Stream Processor (ESP) 5.1

Product

SAP Event Stream Processor 5.1

Keywords

streaming, processing, esp , KBA , BC-SYB-ESP , Sybase ESP (Event Stream Processor) , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.