2508116 - SSO fails for unexplained reasons, possible license errors in java logs or after java SDK upgrade | SAP Knowledge Base Article

SAP Knowledge Base Article - Preview

2508116 - SSO fails for unexplained reasons, possible license errors in java logs or after java SDK upgrade

Symptom

  • BI kerberos SSO libraries cannot launch with certain version of java SDK 1.8.121 and newer.
  • This issue has also been observed with java SDK 1.7.141 (it's possible it was added on earlier versions)
  • An affected system manual logon will work fine but SSO will fail from (launchpad, opendocument, CMC, web services (dswsbobje))
  • To note that the version of java SDK when repackaged such as with SAP and IBM may not reflect the same version # that Oracle JVM displays
  • To get the java version at a dos prompt run the command java -version 
  • The error could vary especially fepending on web/app, most likely the web/app server logs will show some type of licence and or certificate loading error
  • If affected SSO will fail (seemingly for no explainable reason) and manual AD should still work. 
  • Error occurs after upgrading java on the BI server. Reverting to a version prior to the upgrade generally fixes SSO
  • this could also appear on a new install if the install is using the java SDK's above.

Errors noted in the std.err when this issue occursSEVERE: Exception starting filter authFilterjavax.servlet.ServletException: Invalid License.at com.wedgetail.idm.sso.AbstractAuthenticator.initAuthenticator2(AbstractAuthenticator.java:352)at com.wedgetail.idm.sso.AbstractAuthenticator.initAuthenticator(AbstractAuthenticator.java:325)at com.wedgetail.idm.sso.AuthFilter.init(AuthFilter.java:131)at com.businessobjects.sdk.credential.WrappedResponseAuthFilter.init(WrappedResponseAuthFilter.java:56).........


Read more...

Environment

  • SAP BusinessObjects Business Intelligence Platform 4.x (4.0 4.1 4.2 virtually any BI software could be affected since the issue is related to the java version not necessarily BI version).
  • This issue has been also reported on SAP Business Objects Enterprise XI 3.1 and no fix is planned so the work around is the only option
  • Oracle Java SE Development kit 8u121 otherwise known as 1.8 version 121 and later
  • It is possible that Oracle will backport the change to other versions of the java SDK and we've already had a report of it on java SDK 1.7 version 141
  • Any supported Operating System (Linux, Unix, Windows, etc) and version of Active Directory could be used as well.

Product

SAP BusinessObjects Business Intelligence platform 4.0 ; SAP BusinessObjects Business Intelligence platform 4.1 ; SAP BusinessObjects Business Intelligence platform 4.2 ; SAP BusinessObjects Enterprise XI 3.1

Keywords

zie emkba biauth wakba single sign on sign-on automatic logon bkba tomcat websphere weblogic netweaver jvm jre sun ibm  , KBA , BI-BIP-AUT , Authentication, ActiveDirectory, LDAP, SSO, Vintela , BI-BIP-DEP , SBOP Web Application Deployment, Wdeploy , Bug Filed

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.