2498534 - SAP Gateway (OData) service not showing up on the hub OR Loading the metadata for service 'XYZ' failed. | SAP Knowledge Base Article

SAP Knowledge Base Article - Preview

2498534 - SAP Gateway (OData) service not showing up on the hub OR Loading the metadata for service 'XYZ' failed.

Symptom

  • When trying to register a service on the SAP Gateway hub system in /n/IWFND/MAINT_SERVICE transaction selecting the Add Service function:
    • The service XYZ to be registered is not showing up in the list of the corresponding system alias.
      AND/OR
    • On an empty result list No Backend Services found information message is displayed.

OR

  • Loading the metadata for service 'XYZ' failed. Check the error log. message received when trying to load the metadata of a service.
    AND
  • No service found for namespace , name XYZ, version 0001 shows up in the Gateway hub error log (/n/IWFND/ERROR_LOG)
    (Similar error on the backend monitor on the same system in (/n/IWBEP/ERROR_LOG), for example: No service found for namespace /SAP/ or No service found for namespace /SSB/, name ... version ...)

Read more...

Environment

SAP Gateway

Product

SAP NetWeaver 7.4

Keywords

service missing, /iwbep/reg_service, /iwfnd/maint_services, unable to add services , KBA , missing , OPU-GW-COR , Gateway Framework , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.