SAP Knowledge Base Article - Preview

2496553 - Which version of Crystal Reports Server Embedded OEM will be compatible with Java 9?

Symptom

  • Which version of Crystal Reports Server Embedded OEM will be compatible with Java 9?
  • Will Java 9 be supported by CRYSTAL REPORTS SERVER EMBEDDED OEM 2016?
  • The following warning occurs: "Warning: JDK internal APIs are unsupported and private to JDK implementation that are
    subject to be removed or changed incompatibly and could break your application.
    Please modify your code to eliminate dependence on any JDK internal APIs.
    For the most recent update on JDK internal API replacements, please check:
    https://wiki.openjdk.java.net/display/JDK8/Java+Dependency+Analysis+Too"

Read more...

Environment

  • CRYSTAL REPORTS SERVER EMBEDDED OEM 2016
  • JDK 1.9

Product

SAP Crystal Reports Server, OEM edition all versions

Keywords

crystal reports server embedded oem; crystal reports server; oem; java 9; jdk 1.9; java; jdk , KBA , BI-DEV-JAV , BI Software Development Kits (SDKs) - Java , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.