SAP Knowledge Base Article - Preview

2484938 - setup.exe fails to run when installing BI products or add-ons

Symptom

  • Installation of BusinessObjects products and add-ons look like they do not run
  • Checking in task manager, the setup.exe and setupengine.exe can be seen spawning for a few seconds before disappearing
  • Temp folder installation logs (see KBA 1801736) show the following errors:

    Error: Global Poco exception caught
    Error: Class name: class Poco::AssertionViolationException
    Error: Display text: Assertion violation: !_dirs.empty() in file ".\src\Path.cpp", line 518

  • Event viewer logs show the following information event:
    McLogEvent
    Would be blocked by access protection rule  (rule is in warn-only mode) (Common Standard Protection:Prevent common programs from running files from the Temp folder). 

Read more...

Environment

  • SAP BusinessObjects Business Intelligence Platform 4.x (BI 4.0 / 4.1 / 4.2)
  • SAP BusinessObjects Explorer
  • SAP Data Services
  • SAP Design Studio add-on for BI
  • SAP Lumira add-on for BI
  • SAP BusinessObjects Client Tools
  • SAP BusinessObjects Live Office
  • SAP BusinessObjects Dashboards
  • SAP BusinessObjects Crystal Reports
  • SAP BusinessObjects Crystal Reports for Enterprise

Product

SAP BusinessObjects Business Intelligence platform 4.0 ; SAP BusinessObjects Business Intelligence platform 4.1 ; SAP BusinessObjects Business Intelligence platform 4.2

Keywords

KBA , BI-BIP-INS , Enterprise (BI platform) installation, upgrade, patching , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.