SAP Knowledge Base Article - Preview

2473757 - Uploading Media via PlatformWebservices

Symptom

Problem while uploading/creating (PUT) new media (e.g. images or PDFs) with the REST API of platform webservices

When we post to /ws410/rest/medias/<mediacode>/data we get a 500 error (null pointer) in MediaContentResource.java line 53

https://wiki.hybris.com/display/release5/WebService+API+-+Reference#WebServiceAPI-Reference-Media.1


Read more...

Environment

Hybris Platform verison 6.2 (but if doesn't work in any version from hybris 4.5)

Product

SAP Hybris Commerce 6.0 ; SAP Hybris Commerce 6.1 ; SAP Hybris Commerce 6.2 ; SAP Hybris Commerce 6.3 ; SAP Hybris Commerce 6.4 ; SAP Hybris Commerce 6.5 ; SAP hybris Commerce 5.0.3 ; SAP hybris Commerce 5.0.4 ; SAP hybris Commerce 5.7 ; SAP hybris Commerce Suite 5.2 ; SAP hybris Commerce Suite 5.3 ; SAP hybris Commerce Suite 5.4 ; SAP hybris Commerce Suite 5.5 ; SAP hybris Commerce Suite 5.5-1 ; SAP hybris Commerce Suite 5.6 ; hybris Commerce Suite 4.4 ; hybris Commerce Suite 4.5 ; hybris Commerce Suite 4.6 ; hybris Commerce Suite 4.7 ; hybris Commerce Suite 4.8 ; hybris Commerce Suite 5.0 ; hybris Commerce Suite 5.1 ; hybris Commerce Suite 5.1.1

Keywords

webservice media put post , KBA , CEC-COM-CPS , Commerce Platform & Suite (SAP Hybris) , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.