SAP Knowledge Base Article - Preview

2447973 - Apache Security Issue - Struts Jakarta RCE vulnerability

Symptom

It is possible to perform a RCE attack with a malicious Content-Type value. If the Content-Type value is not valid an exception is thrown which is then used to display an error message to a user.


Read more...

Environment

SAP NetWeaver Application Server Java

Product

SAP NetWeaver all versions

Keywords

Apache Jakarta multipart parser RCE Remote Code Execution vulnerability struts S2-045 CVE-2017-5638 , KBA , BC-JAS-WEB , Web Container, HTTP, JavaMail, Servlets , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.