2399249 - SMP server can't start after upgrade to sp11 - agentry bundles not yet initialized - SAP Mobile Platform | SAP Knowledge Base Article

SAP Knowledge Base Article - Preview

2399249 - SMP server can't start after upgrade to sp11 - agentry bundles not yet initialized - SAP Mobile Platform

Symptom

  • After upgrade SMP from SMP 3.0 SP9 to SP 11, the SMP server could not start, you will find below message in SMP server log and Agentry event log.
    • Bundles (and their services) not yet initialized: com.sap.mobile.platform.server.agentry.core <-- Issue
    • Bundles (and their services) not yet initialized: com.sap.mobile.platform.server.proxy.core <-- Issue
  • When you check the osgi log, you will find error message like below.
    • !MESSAGE An unexpected runtime error has occurred.
    • Local Exception Stack:
    • Exception [EclipseLink-4002] (Eclipse Persistence Services - ***): org.eclipse.persistence.exceptions.DatabaseException
    • Internal Exception: java.sql.SQLException: Invalid column name 'ISOTPREQUIRED'.
    • Error Code: 207

Read more...

Environment

  • SAP Mobile Platform 3.0 SP09
  • SAP Mobile Platform 3.0 SP10
  • SAP Mobile Platform 3.0 SP11

Product

SAP Mobile Platform 3.0

Keywords

agentry.core, bundles, initialized, start, smp, upgrade, proxy.core, com.sap.mobile.platform.server, ISOTPREQUIRED , KBA , smp , MOB-SDK-AGS , SAP Mobile SDK Agentry Development Server , MOB-ONP-AGS , SAP Mobile On Premise Agentry Server , MOB-ONP , SAP Mobile Platform on Premise , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.