2371668 - XMLStreamException error in SOAP version mismatch | SAP Knowledge Base Article

SAP Knowledge Base Articles - preview

2371668 - XMLStreamException error in SOAP version mismatch


In the IFlow you are using 2 or more SOAP calls to WebService Endpoints. Some of the Endpoints are called using SOAP 1.1 others are called with SOAP 1.2 protocol. During the message processing in SAP Cloud Platform Integration the following error happens:

Caused by: javax.xml.stream.XMLStreamException: prefix soap has been already bound to http://www.w3.org/2003/05/soap-envelope. Rebinding it to http://schemas.xmlsoap.org/soap/envelope/ is an error
 at com.sun.xml.internal.stream.writers.XMLStreamWriterImpl.writeNamespace(XMLStreamWriterImpl.java:1035)
 at org.apache.cxf.staxutils.DelegatingXMLStreamWriter.writeNamespace(DelegatingXMLStreamWriter.java:131)
 at org.apache.cxf.staxutils.StaxUtils.writeStartElement(StaxUtils.java:874)
 at org.apache.cxf.staxutils.StaxUtils.copy(StaxUtils.java:737)
 at org.apache.cxf.staxutils.StaxUtils.copy(StaxUtils.java:701)
 at org.apache.cxf.staxutils.StaxUtils.copy(StaxUtils.java:649)
 at org.apache.cxf.binding.soap.interceptor.SoapOutInterceptor.writeSoapEnvelopeStart(SoapOutInterceptor.java:173)
 ... 60 common frames omitted



  • SAP Cloud Platform Integration for process services


SAP Cloud Platform Integration for process services 1.0


HCI, HANA Cloud Integration, worker node, endpoint URL, SOAP protocol, SOAP 1.1, SOAP 1.2, SOAP version, namespace, SAP Cloud Platform Integration , KBA , LOD-HCI-PI-RT , Integration Runtime , LOD-HCI , HANA Cloud Integration , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.