2366912 - Error 140 raised when update() function is used in a trigger | SAP Knowledge Base Article

SAP Knowledge Base Article - Preview

2366912 - Error 140 raised when update() function is used in a trigger

Symptom

Error 140 "Can only use IF UPDATE within a CREATE TRIGGER" is raised when update() is used in trigger code.


Read more...

Environment

  • SAP Adaptive Server Enterprise (ASE)
  • SAP Adaptive Server Enterprise Cluster Edition (ASE CE)

The sp_configure 'procedure deferred compilation' setting is turned on.

Product

SAP Adaptive Server Enterprise 15.7 ; SAP Adaptive Server Enterprise 15.7 Cluster Edition ; SAP Adaptive Server Enterprise 16.0 ; Sybase Adaptive Server Enterprise Cluster Edition 15.0 ; Sybase Adaptive Server Enterprise Cluster Edition 15.5 ; Sybase Adaptive Server Enterprise Cluster Edition 15.7

Keywords

KBA , BC-SYB-ASE , Sybase ASE Database Platform (non Business Suite) , BC-SYB-ASE-CE , ASE Cluster Edition (Standalone) , Bug Filed

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.