2363574 - Salesforce Adapters unable to connect after certificate updates - Data Services | SAP Knowledge Base Article

SAP Knowledge Base Article - Preview

2363574 - Salesforce Adapters unable to connect after certificate updates - Data Services

Symptom

  • Salesforce adapters fail to connect after security certificates and Java JVM were updated.
  • Datastores apply updates failed with the following error:
    Error "Adapter connection failed. Could not create a new session (Adapter: <Adapter Name>)"
  • Saleforce  and Simba for Salesforce adapter error log has the following error:
    Error "There was a communication error when talking to Salesforce.com: The host did not accept the connection within timeout of 30000 ms"
  • Simba for Salesforce adapter will fail during job run with following error:
    Error: " Error preparing to read <Qry_SFDC_ACRDLY_Map1>:
    <Cannot start session. com.acta.adapter.sdk.AdapterException:
    [Simba][SimbaSalesforceAdapter](100005) Error connecting to the database. 
    java.sql.SQLException: Error message not found: LICENSE_FILE_READ_ERROR. Can't find bundle for base name com.simba.jdbc.common.licenseMessages"
  • User can still connect to the Salesforce.com website with existing account.

Read more...

Environment

SAP Data Services
SAP HEC

Product

SAP Data Services 4.2

Keywords

KBA , EIM-DS-EXE , Data Services Job Execution , EIM-DS , Data Services (Use Subcomponent) , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.