2243588 - user_status in sysusers on system roles shows non-zero values after upgrade to ASE 15.7 SP135 using dump and load | SAP Knowledge Base Article

SAP Knowledge Base Article - Preview

2243588 - user_status in sysusers on system roles shows non-zero values after upgrade to ASE 15.7 SP135 using dump and load

Symptom

  • When executeing sp_helpuser, a message "Resolve as Owner user mapping" displays  but no rows are returned. For example:

1> sp_helpuser
2> go
Users_name ID_in_db Group_name Login_name
 ---------- -------- ---------- ----------
 ERISCO             3 public     ERISCO  
 dbo                    1 public     sa        
 usedb_user        4 public     NULL     
(1 row affected)
Resolve as Owner user mapping
(return status = 0) 

  • Column ‘user_status’ is newly added to the sysusers system table starting with ASE 15.7 SP130.   
  • On target database in ASE 15.7 SP135, when the empty database is created, the column 'user_status' of sysusers on all system roles have the value 0 (zero).   
  • After loading the dump from various platforms to target database, the 'user_status' values in sysusers on system roles change to different values.  

Read more...

Environment

  • SAP Adaptive Server Enterprise (ASE) 15.7 SP130 to SP136
  • SAP Adaptive Server Enterprise (ASE) 16.0

Product

SAP Adaptive Server Enterprise 15.7 ; SAP Adaptive Server Enterprise 16.0

Keywords

792229, CR792229 , KBA , BC-SYB-ASE , Sybase ASE Database Platform (non Business Suite) , Bug Filed

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.