SAP Knowledge Base Article - Preview

2241220 - JDBC driver not supported for ORACLE database 12.1 although SAP Note 1777021 was applied

Symptom

Java AS Server cannot be started after changing the Oracle JDBC driver to version 12:

jvm_bootstrap.out contains the following error:
...
Caused by: com.sap.sql.log.OpenSQLException: JDBC driver not supported for ORACLE database.
...
Additionally the opensql implementation jar file in the cluster directory is not on the required level even though the SAP Note 1777021 was already applied.
E.g.:
unzip -c  [DIR_INSTANCE]/j2ee/cluster/bootstrap/sap.com~tc~bl~opensql~implStandalone.jar META-INF/MANIFEST.MF | grep Implementation-Version
gives back the version: 7.3101...

However the required SP level is SP7 for version 7.31 (therefore the version should be at least 7.3107...)

The required version details are in the SAP Note:
#1777021 - J2EE: Introducing Support for Oracle 12


Read more...

Environment

  • SAP NetWeaver Application Server for Java
  • Oracle JDBC Driver 12
  • Oracle Server 12.1

Product

SAP NetWeaver Application Server for Java all versions

Keywords

KBA , BC-DB-ORA , Oracle , BC-JAS-COR , Enterprise Runtime, Core J2EE Framework , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.